PDA

View Full Version : Repairs: Imp. Troop Transport



Ken
12-06-2001, 05:42 PM
I'm trying to get my vintage Imperial Troop Transporter working again. Has anyone out there ever fixed one? Is there a website that explains this? I could use some help.
I cleaned off the connections and got the motor running, but it won't shut off without removing the battery. There's this copper strip that regulates the motor somehow - can't see how. Also, I remember taking out a rubber belt years ago - it drives the disk with the voice samples. I can see how it would fit around the motor and the disk . . .I'm thinking a large plumbing O-ring would do the trick.
Also, I'm new to the Forum, so excuse me if I am dredging up old topics, but has anyone figured out how to print reproduction stickers for vintage vehicles and playsets?
Thanks for reading,
Ken

Rollo Tomassi
12-06-2001, 06:54 PM
Actually, my local comic shop has one of these that I've had my eye on for awhile. If I pick it up, I'd be interested to know as well, since it isn't in working order. BTW is $25 a good price for a non-working one of these?

Ken
12-06-2001, 07:08 PM
Rollo, I can't say what the transport is worth . . . the safe answer would be "what you're willing to pay" If it works, I'd say it's a good deal at $25. If not, and I'm thinking the rubber belt has dried out and snapped like mine, maybe you'll get lucky and find a way to repair it. -Ken

bigbarada
12-06-2001, 07:36 PM
Go to www.sandcrawlerworkshop.com

He repairs and restores old Star Wars toys. I can personally vouch for him as he fixed up my old beat up Cloud Car and it looks great.:)

Ken
12-06-2001, 09:12 PM
bigbarada, thanks for the lead to Sandcrawler . . . sounds like this guy can do it. I emailed him with my problem - hopefully he be able to fix it. Thanks! Ken