PDA

View Full Version : MMC C-3PO Molting?!?



JediTricks
05-13-2004, 12:57 AM
I just took a gander at the Millennium Minted Coin C-3PO that I have standing loose in my collection and when I picked him up, he felt funny. Not only that, but upon closer inspection, he looked different from how I remembered him. When I went to set him back down, I realized those issues were because his gold color had badly cracked and was coming off in small pieces!!! Underneath is silver, so anybody who missed out on TC-14 should be happy :rolleyes: but for anybody with a loose MMC 3PO this is a disaster! I plan on replacing mine with the Saga HOF version the next chance I get, but I'm really honked because I paid $10 for this figure and have been touting its quality to fellow collectors for years. Anybody else notice this?

Deoxyribonucleic
05-13-2004, 02:53 AM
well, I just pulled mine down from my closet shelf, still in the box (I did have him displayed loose at one time, but not for long, then I put him right back in his box) and sure enough, on his leg a piece has come off, although mine is not silver underneath, he's a mat whitish-green color. Then there's also little "stress" lines all over his body and extremities, so yeah, I'm having the same problem :(

plasticfetish
05-13-2004, 06:19 AM
That's weird. I was thinking, what year did that thing come out? Was it the same year as the later Beast Wars then Beast Machines stuff that sometimes had similar chrome chipping/peeling problems? Hasbro may have been having a lot of chrome problems around then. I ended up tossing out a few TFs because of that same problem.

Hellboy
05-13-2004, 05:53 PM
I looked at mine and it appears to be fine. Hopefully I won't encounter that problem down the road because this is my favorite Threepio.

If you were to replace it with the HOF version wouldn't the same problem arise eventually with that one too?

JediTricks
05-13-2004, 11:45 PM
Wow, it's molting in the box Deoxy? That's terrible, if I knew were my boxed version was, I'd not want to look now. Probably the limbs and the torso aren't cast in the same material, or perhaps the look of the figure involves 2 chrome finishes and both came off on yours.

PF, I looked 'em up, sure enough the MMCs came out in '98 just like the Beast Wars Transmetals and TM2s. I guess the colored chroming process Kenner division was using at that time was just not made to last - this might explain why the Japanese got jittery about the '95 3PO (even though mine has had no problems) and required an alternate version be made for their country.

Hellboy, I would HOPE that Hasbro has updated the process by now and it won't do this (which might explain why the HOF 3PO I saw the other day had a different color of gold on the right leg than the rest of the body).

plasticfetish
05-14-2004, 12:32 AM
PF, I looked 'em up, sure enough the MMCs came out in '98 just like the Beast Wars Transmetals and TM2s. I guess the colored chroming process Kenner division was using at that time was just not made to last -
Yeah, that makes sense. And it's weird, because not all of my transmetals/beast machines stuff had that problem. Only (I think) two figures -- and I remember looking all of my stuff over after talking about this in the TF thread ages ago. The chrome basically started flaking off in huge pieces. I haven't had this happen with any other toy (my vintage 3POs are still fine) so I'd assume that the new HOF version is probably safe.

Found one today BTW, never had one from before -- very nice figure!

About the Japanese 3PO... I'd thought that the different color was due to some kind of safety concern about the kind of gold chrome regularly used being dangerous if swallowed. (Not that any of it could ever really be good for you I suppose.)

JediTricks
05-14-2004, 08:39 PM
You are right about that Japanese 3PO, I was factoring that into my theory.

Nearly half my Transmetals and nearly all of my TM2s have some level of colored chrome coming off, though usually in chips around seams and edges. This is part of why I ended up buying the Saga version of TM Airazor, the other part being that I preferred the new paint job on both the figure and the Minicon.

I think the reason the Vintage 3POs don't have these kinds of problems is because Kenner used a different process and had the color IN the chrome, on mine the color has significantly faded but nothing ever came off.

JEDIpartner
05-17-2004, 10:12 AM
Damn! That really sucks! I haven't had that problem with mine yet. I just took a look at him the other day. I wonder if heat or humidity played a role for the decomposition of the veneer.

plasticfetish
05-17-2004, 11:10 PM
I wonder if heat or humidity played a role...
Yeah, I think it must. All of the chrome problems that I've had, came a few years ago after my stuff had sat in storage (a nice warm lock-up) for a bit while we moved. But again... I've only had this problem with a few specific chromed toys from around that time.

JediTricks
05-18-2004, 03:57 PM
Anything's possible, but mine hasn't exactly been sitting in the hot Arizona sun for the last 6 years, and most of my Transformers with the chrome problem from this era had problems since day 1.

JEDIpartner
05-19-2004, 10:52 PM
Hmmm... since all of the figures were made around the same time... I can't believe that I haven't had this problem yet. I hope I don't (touch wood)!!!

JediTricks
05-21-2004, 05:53 AM
I found my MIMP figure and there appear to be cracks formed in some areas, though they might be chrome swirls that were always there... I'm not taking it out and touching it to find out though. :eek: :p