Results 1 to 5 of 5
  1. #1

    vintage x-wing not working

    I have tried to see what is wrong with a X-Wing from 1978, but no luck. Is it a motor at the bottom of the ship that could be wrong or what? It is not the batteries and not the wires as far as I can see. Any ideas?


  2. #2

    Re: vintage x-wing not working

    I need some more info before I can help. You're 100% sure the batteries work (i.e. you've tried them in something else and they have worked)? Does the LED light up? And when you say its not the wires I assume that have already opened her open, correct?
    I'm pretty busy currently, so I might not get back to you right away. But any answer those question, the LED is the most important, and I should be able to help.
    "I'm sick and tried of these motherfrakkking Sith on this motherfrakkker plane!"
    Mace Windu - Episode 2.5: Sith on a Plane

  3. #3

    Re: vintage x-wing not working

    OK, I have tried the batteries and they are fine. The LED does not light up at all. I have opened up the ship and I cannot see anything wrong.


  4. #4

    Re: vintage x-wing not working

    All right in my experience you've got one or two things going on. First is your battery terminals are corroded. Even if the motor doesn't run the LED should light up. One thing I forgot to say earlier was you should try the batteries both ways. The motor will run even if the batteries are in backwards, but LEDs will work only one way. The second thing is the motor may need a kick start.

    I always start with the easiest thing to fix and work my way to the hardest. The in this case the terminals are easier to clean than playing with the motor. I use white vinegar to clean the terminals because it's readily available to me, I don't care if I spill it on my hands, and it does the job. Both sets of terminals should look shiny like a new penny. Try soaking a small piece of paper towel in the vinegar and placing that on the terminals. Check back in 10 to 15 minutes and see what progress has been made. You may need to rewet and soak it longer or rub it a little bit. Either case you want all the battery terminals to be clean and shiny. Once you've cleaned the battery terminals try the batteries both ways again to see if the LED will light up. Very rarely will a LED not light up when the battery terminals are cleaned.

    Next thing to do is see if you can get the motor running. With clean battery terminals it may run on its own. Try holding down the button for couple minutes and see if the motor won't start on its own. If it doesn't I usually drip some vinegar into the motor and let that soak for a minute or two. Then I will try pushing down the button again and see if the motor runs. Again hold down for a little bit of time to let things get going. My guess is the motor hasn't been run in a while so it might start slow.

    Now this vinegar in the motor deal isn't always a permanent solution. Some of my stuff works as long as the motor is wet and others soaked it once and they're still running.

    I hope that helps. If you have more questions or need clarification on anything please ask.
    "I'm sick and tried of these motherfrakkking Sith on this motherfrakkker plane!"
    Mace Windu - Episode 2.5: Sith on a Plane

  5. #5

    Talking Re: vintage x-wing not working

    Wow! What an explaination! I do not know which part of it all worked, but the ship works! I do not think the contacts were that corroded, but I washed the surfaces with vinegar, rubbed the surfaces a little with some sandpaper and with the batteries in place and the top contact on I spun the motor and it started. The LED shines and the machine lets out a noise, more like a motor running than lasers. But perhaps that was what the ship sounded like 25 yrs ago, I cannot remember. Any input there?

    This justs shows what a powerful tool the internet is. Thanks LusiferSam!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Single Sign On provided by vBSSO